Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
frons4

no restart after its warmed up.. wait half hour fires right up

Recommended Posts

hey guys I have an 1989 626 2.2 w.o. turbo.. was running ok until fuel pump quit  I replaced that, and starts fine cold drive ten- fifteen min. stop and it will still start, but wait ten-fifteen min. and try no start have to wait about half hour maybe more and starts fine... id say maybe vapor lock??  but its got fuel injection    any clues out there ???  got me stumped  thanks

Share this post


Link to post
Share on other sites

I don't know much about the design of the 1989 626s but it almost sounds like a bad coolant temp sensor. You know when the engine warms up and its reading higher than normal temp and then it shuts down and never restarts to protect it from overheating. Or it can be a resistance in the wiring somewhere that is affected by the temperature of the heat.

You can also check for spark when it doesn't start back up.

Other then that, can't really say. There's a lot of variables.

image.png.3938a3f55314139fa75ddb45b693a15d.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...