Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Sign in to follow this  
ThexTallxDude

Transmission/Idle issues

Recommended Posts

I recently got a 1996 Mazda 626 on the cheap, and it's got some quirks I'm trying to track down.

When you first start it in the morning, the car idles at 2k until it gets to temperature, where it settles down at 800 RPM. It also shifts a bit hard when cold, and the first time it hits 25 mph after a cold start, the revs jump up to 5k before the car shifts and continues forward  (the car has to sit for 5 hours or so before it's reproducible)

I haven't checked much other than fluid levels so far, to make sure the transmission wasn't running dry or something. I've repaired all my vehicles in the past, but as they've been all motorcycles, I'm not entirely sure where I should start. I'm hoping the high idle is just a vacuum leak somewhere, but I've heard some cars idle high when cold by design, which sounds really odd.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...