Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

Recommended Posts

I recently had oan intermitant heater problem then my 02 mazda 626 began t run hot. I flushed radiator which looked like brown mud, flushed heater core and refilled with new antifreeze. The car ran great for two days. then the engine started overheating into hotzone right at the line. I had already replaced the thermostat.I figured it was the coolant temp sensor and last night I was going to replace it. I first drained some of the anti freeze out of the radiator and couldn't believe I have oil mixed with the anti freeze. any suggestion as what caused this would be appreciated. Is it possible I blew a head gasket. I hSD  mechanic FRIEND TELL ME THAT I HAD A BAD RADIATOR. How ever the oil cooler line doesn't enter into the radiator.  Any thoughts on what caused this or what the problem could be would be greatly appreciated.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...