Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
darkbreeze

Left dash signal indicator

Recommended Posts

Crazy issue. All turn signals and flashers work when they should. Except that, the left signal indicator on the dash cluster intermittently doesn't work.

I've pulled the dashpod, replaced all the bulbs (Because I had it out, and why not?) and the bulb holder for the left signal. Checked the printed circuit with a magnifying glass and ohm meter. I don't see any issues anywhere.

Left signal generally always works when I first get in the car, and for the first five minutes or so. After driving for a few blocks the left signals still work, the bulbs at the front and back light as they are supposed to be the indicator bulb on the dash stops working. It does not light up at all. What is weird, is that when it stops working it begins to, very dimly, flash the headlight bulb for the highbeams. If you aren't specifically looking for something to be flashing you won't even notice that that is. During the day you can't tell at all, only at night when it is otherwise dark.

 

Is there some relationship with the signal and headlight high beam circuit, perhaps in the combination switch, that could be causing this problem?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×