Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
FarmerGirl626

Replaced Slave cylinder and clutch still wont stay primed

Recommended Posts

Okay so I picked up a 97 626 from a friend of mine. They had the clutch replaced it drove fine when I test drove it but once I got it home that's when the trouble started. It's as if the clutch won't stay primed. Already replaced the slave cylinder but didn't solve the problem any tips?

Share this post


Link to post
Share on other sites

I am in the process of replacing the metal flared line that goes into the slave cylinder. Mine had a small hairline split in it that could only be seen while hand pumping the clutch petal. I would try bleeding the slave cylinder again to release any air and then have someone pump the clutch until you find the leak between the slave cylinder and the master cylinder. Most likely you will have a leak somewhere on one of those lines

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...