Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
bobp1

2001 cranks but no start - may be faulty immobilizer system?

Recommended Posts

                 *Edit*

I probably should have done a little more troubleshooting first but gambled instead and ordered a non-immobilizer PCM off of eBay today for about $100 after shipping and tax.  I found two instances on the internet where people had successfully replaced the immobilizer PCM with a non-immobilizer PCM on pre-2000 626s (one of those done by a Mazda dealer when they couldn’t fix the problem with the immobilizer!) but couldn’t find any examples of it being done on the 2000+ cars.  I think it should work but also know they changed the immobilizer system in 2000, making it more sophisticated with rolling random codes.  So keeping my fingers crossed and I’ll post whether or not it works.

Hi Folks,

I’m hoping that someone on the forum has in-depth knowledge of the immobilizer system used on the 626.  I just picked up a non-running 2001 with the 2.0/manual transmission and 92,000 miles that cranks over but won’t start.  I think the immobilizer system is malfunctioning (no spark or fuel) but I’m hoping that someone might know how to troubleshoot the system for sure.

The reason I think it is the immobilizer system is that the security light (“outline of car with key inside” symbol) in the instrument cluster is not coming on at all. According to the owner’s manual, “If the immobilizer is working properly, the light will come on when the ignition is turned to the start position” and if the light “fails to come on, it indicates a system malfunction.” The owner’s manual says that malfunction can be indicated by the light flashing, staying on, or not coming on at all.  The light on my car doesn’t come on at all.  Does anyone know if the light not coming on at all points to a particular problem, and would someone mind turning their key and letting me know when and if the security light comes on and turns off?

Another thing that’s got me stumped is that I’ve read that if the immobilizer system isn’t working properly that it should set a code, but I checked with a code reader and I don’t have any codes set.  The code reader in live RPM mode does see the engine turning over when the engine cranks with the starter, so I’m thinking the crankshaft position sensor is working and is not the problem.

Anyone have any insight into this issue? I found a thread on mazdaforum.com from 2006 where the poster said that he solved the problem by installing a rebuilt ECU ($250 after core) and new immobilizer (about $200), and another thread where someone with a 1998 626 replaced their ECU with a non-immobilizer ECU, and he said that worked too.  Though I believe the immobilizer system changed from the 1999 to the 2000 model year, and I’ve read that all 2001 626s have the immobilizer, but RockAuto lists ignition switches with and without immobilizer, so I’m not sure what is up with that. 

I know I’ve thrown a lot of info and questions out there, but I hate to start installing new parts without knowing for sure what the problem is first.  I thought getting the car running would be simple but it’s turning into a pain.  I've done a lot of searching on the internet but couldn't come up with much good specific info.

Thanks in advance for anyone that might be able to help!

Share this post


Link to post
Share on other sites

l can tell you that what you said about 2001 and after have imm. thats not so my daughters 626 2.0l auto Did Not have an immobilizer  it was a 2002. My 1999 626 2.0l auto has immobilizer and i lost 1 of the keys, so I got the numbers off the unit located next to the OBD2  port called a company and got the 8 digit code, I bought a Real mazda blank had it cut and then had a couple shots of JD and went over and over the info on how to program the 2nd key, I posted the instructions here or Djvon did for me it's a nightmare to do , I got it first time, drinking helps.... Anyway I know that if you try and start car with the wrong transponder key or one not programmed to the car 3 times in a row the computer will shut down and keep car from starting, go ahead ask me how I know this ! DON'T USE CLONE KEY BLANKS they won't  program to key programming hack. I had to take to dealer and have it brought back to life.. I don't have to worry about that any more since I bought a NGS STAR SCAN TOOL ( Pic's posted here )a Mazda card for the image of ECU and the diagnostics card, and wife has a 04 SHO Taurus so I have bought all the cards for keys and CAN , sorry I got off track. So maybe problem might have been ignition,  key, Did you have spark gas, fuel pump, fuel pressure . I think that's as much as I know, wondering about harness .Scan tool, you don't have  to spend a lot. Start  by getting an Elm327 ver.1.5 you don''t need the one with switch std. mode is HS which will read what you have, you can get BTHOOH for 12 bucks I got a Kobra from Amazon. Then download Forscan search google for it, and you can buy the key,security system program from them the main program is dealer level and Free key stuff cost so crooks don't take advantage . It's only for Ford Mazda. So don't try a unknown key, get starter fluid give a shot see if it hits then go from there.

Share this post


Link to post
Share on other sites

Thanks for the replies and no, I didn’t get it running but haven’t had a chance to look at it much.

I want to check to see if the fuel pump is working. Removed the fuel pump relay and used a jumper wire to ground terminal 30 like it shows to do in the service manual, but it didn’t work.  And I also tried it on my 2002 parts car which does run, and it didn’t power up and run the fuel pump on it either.  Has anyone used the jumper wire technique as shown in the service manual, and did it work?

I did download the 2001 service manual from pmx626 and it’s great!

Share this post


Link to post
Share on other sites

Sorry I didn't post this sooner but between the site being down and life's busyness, I'm just now getting to it. Plus I'm a little embarrassed that the problem turned out to be so simple and I didn't figure it out sooner.

I bought the 2001 626 in February of 2018 and it sat in the driveway until April of 2019 when I swapped out the coil from my parts car and it immediately fired up! So after all the messing with the immobilizer, it turned out to be just a bad coil pack. What had thrown me though was that I didn't have spark or fuel and that's what made me think immobilizer. 

After the car was running, it was hard starting (extended cranking time) especially in the morning or after it had set for several hours. That turned out to be the fuel pump and I swapped out the fuel pump from the parts car (its pump looked like it had recently been replaced). The parts car also donated its good battery and right rear door window regulator (my rear passenger window wasn't working) before it was hauled off for scrap. 

Several other things needed attention, including replacing a leaking AC evaporator (thanks Rock Auto), tracing down a loose connector near the fuse box (headlights weren’t working), bad right front wheel bearing, brake fluid flush (it was dark orange/brown with spongy brakes), replacing rear sway bar bushings, refinishing the cloudy headlights, and sealing up the leaky trunk (me in the trunk with a flashlight and wife running garden hose on the back of the car).

The car runs like a top now (27+ mpg mixed driving) and we’ve put over 5,000 miles on it. We have two newer cars but I really like driving the little 2.0 5 speed 626!

Just curious - how many people out there still driving 626s and monitoring this site? Even the 2002s are now 18 years old...

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...