bmail

Engine stops when driving at idle

1 post in this topic

Hello,

I own a 1998 european Mazda 626 GF with the 1.8L 4 cylinder engine and manual transmission.

I'm a almost complete newbie with mechanical technics and since few months, this car has a problem:

 

As soon as the engine is beginning to be hot (4 or 5 mins at idle), the idle regime become very unstable, between 500 and 750 rpm. And without charge, after an acceleration,  a deceleration leads to stop the engine.

And, which is very annoying, when driving and positioning to neutral in order to stop, the engine stops. So so more assisted steering ... which is dangerous. Brakes work for this simple task.

I tried to test electrically the IAC. It seems to be high: 9,2 to 10,8 ohms ( 7,7 to 9,3 ohms at 23°C according workshop manual), but test here at 10°C.

I measured the voltage at MAF:

With just ignition: 0.03 volt

*** Engine cold:

750 rpm >> 0.94 volt , idle stable.

4000 rpm >> 2.10 v

And suddenly, after 5 mins at idle ...

*** Engine hot:

idle at 750 rpm >> 1.28 v  ,  the idle is unstable and slow down, like the voltage: 1.22v,  and between 500 and 750 rpm: 1.08v

2500 rm: 1.62v

4000 rpm: 2.10v

I don't known if the values are normal for this engine.

For sure, the rpm indications come from dashboard, not with a stroboscopic light.

When driving, there is not lots of power (but, it's just a 90 hp engine) below 3000 rpm. But, sometimes, from 3250 rpm to 6000 rpm, this engine works very very well and accelerate very well, as unusual. As if this engine would deliver more than 90hp. In fact, similar as an Honda Aerodeck with 122hp which is less massive than my 626 !.

I'm not searching for performance. I'm just trying to recover the mazda that I used ... Just a car which works correctly between idle and 3000 rpm ... It's enough for me !

Unfortunetly, this car, sold in France, doesn't have an OBD socket with engine diagnostic. Just the OBD 1 socket without TEN, MEN, FEN, pins (as described here https://mazda626.net/topic/42924-european-mazda-626-1998-18-no-ten-pin-in-obd-module/

And no OBD socket inside the car.

So I can't get error code for engine, just ABS and airbag error code.

Does somebody have an idea to help me with a diagnostic ? I can't replace MAF, IAC, etc ... randomly , with my budget, and I can't ask to a Mazda professional for financial reasons.

Thank a lot in advance for any help or suggestions !

Best regards

Bertrand

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now