Sign in to follow this  
My First Mazda

New 626 owner, same 626 idle problems

2 posts in this topic

Hey everyone!

I just picked up a 1997 626 LX 2.0 manual as my new daily driver/beater.

So naturally, I have the very common idle issue along with many others, and it's been beaten to death.

Maybe my issue is different?

It seems to idle at what should be normal - around 700rpm but jumps up and down very slightly to 500rpm at a fast constant annoying rate. A definite rough idle feeling overall.

I have done lots of recent work and diagnosis. When I bought it, it would stall out constantly and idle very poorly.

So, I started out by replacing the obvious things it needed immediately:

The rusted leaking downpipe and the original rusty rear catalytic converter. - got quieter.

Gapped all NGK iridium spark plugs (It had them in there already and still in good shape) to 0.44 - not much change.

Topped off coolant - nothing.

Checked the IAC , found a normal 8.4 ohms

New spark plug wires, cap, rotor - the idle got a little better. 

I know that 90's japanese cars had major issues with the capacitors in the ECU leaking, and I have considered that as a possibility.  

I have read that people have done many things to fix this issue:

Intake manifold gasket, adjusted timing, throttle position adjustment or replacement, coolant level, new distributor, new engine due to low compression, etc. I have not checked timing or adjusted the TPS since it seems like everything takes a special tool or a Mazda OEM scan tool. It doesn't seem to drive like any of these are bad, it has plenty of power and no hesitation throughout the whole throttle range.

The breakthrough - I found if I disconnect the "closed throttle position switch" on the throttle body the idle gets back to semi-normal and gets much smoother. Also when disconnected on cold start, the idle jumps between 2000 and 500 real fast and then gets normal. 

This is the switch that gets depressed when the outer throttle plate hits it and tells the ecu to go to a idle condition. 

It seems only the manual transmission cars have these.

I attached a picture of the switch, it's on the right side of the throttle body where the throttle cable attaches.

If that switch is plugged in as normal,  you get poor rough idle. If you adjust the idle air screw, it gets slightly better but makes a loud sucking noise. At that point it is way too high and the screw is backed almost all the way out which it is never supposed to be. 

As a cheap guess, I have a used throttle body coming and I will try that one to check. I'm pretty sure that "closed throttle position switch" is adjusted at the factory. There is no information on adjustment or even being able to get the part without buying a throttle body so I won't mess with the one on my car.

Other than that problem, it's an enjoyable car to drive, and I'm not having buyers remorse.

So what really fixes this issue? Has anyone else seen this?

 

aa027986-new-oem-1996-1997-mazda-mx-6-mazda-626-20l-export-throttle-body-424671635.jpg

Share this post


Link to post
Share on other sites

Yeah this seems to be common, especially in the GF/W platforms in particular.

 Bouncy idle sounds vacuum related to me. Spray carb clean/crc around the intake manifold to check if you have a manifold leak. Have you tried cleaning the throttle body with throttle or carb cleaner? I'd go to Autozone or Supercheap and get a scan done to rule out anything electrical like EGR or map sensor which could possibly contribute. Fuel pressure has occasionally been known to upset idle on these too, I'd check the FPR as well, good clean filters - fuel, air also seem make them a bit happier too. Hopefully this is a step towards the right direction.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this