Sign in to follow this  
Yrid

My Mazda 626 cranks no start no spark

2 posts in this topic

I have a 96  mazda 626 2.0 it cranks but won't start has no spark we have tested everything. We plugged in the OBD11 tester and my husband thought I said try to start car while it was plugged in and the car fired right up. We checked relays fuses bought new distributor new crank shaft sensor we notice from the distributor to the crank shaft sensor there is no juice. We tried resetting the ECU by taking negative battery cable off and holding brake down and everything else... The only thing we have not looked at is the ignition itself but the only way this car will start is with the obd11 tester plugged in.. Also that just  reads error and gives me nothing to follow up on. I'm about ready to drive it over a cliff unless somebody helps me and gives me some leads to check 

Share this post


Link to post
Share on other sites

hello, ive got an 02 2.0L, and currently going through the same thing after a rebuild from a head gasket.

Virtually no problem for 'bout a month, and a sudden change of the distributor cap seemed to send me spiraling down a similar path as yours.

i  fell sad to see no replies to such an old comment. and in best wishes that you overcame this with a solution, will you please share what became of this problem if not suggest any great cliffs :smile:

Till then i  shall continue to do what DIY does best. Dig.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this