Sign in to follow this  
Followers 0
Tvaughan67

Random engine stalls

2 posts in this topic

01 mazda 626 2.0 atx

Hey guys i have read a bunch of the forum posts here throughout the proccess of putting an engine in my 626 and you guys are always super helpful! im a new member and need yalls opinions. I just put a salvaged engine into this 626. It has all new gaskets, seals, and fluids now. It will start right up every time,The problem is after it starts it will idle normal (700rpm)  and seem fine for a minute. But then randomely the engine will shake a little and the rpms drop down to like 300 and it will almost stall but then start running normal again. And it doesn't do it all the time, pretty sporadically and really just randomely. Then i test drove it around the block and sonetimes when i come to a stop to turn or stopsign it will almost stall and die. Unlike while idling it isn't as random, it almost stalled probably 2/10 times i stopped. Also dont think its related but brakes seem to be extremely stiff And hard to push. They work, just have to really mash down the pedal. Also there's no codes being thrown. Any suggestions? Thanks

Share this post


Link to post
Share on other sites

I'm not sure this if this is exact problem as yours but it is similar, I believe. Click The box and it'll take you to this post where others have suggestions 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0