Jump to content

Recommended Posts

HELP! I have been a ghost user on this because of all the advice or steps from others' on here. but finally I have come across something that Im not too sure of.

Im now starting to take some pride in learning how to just do things myself when it comes to cars. Anyways, about a month ago I was driving and my heater kicks off, then my break warning light comes on, and I get a burning smell, as Im trying to find a place to park I noticed my headlights were on but my headlight switch was not in the "on" position. My first thing was to just check fuses, didn't see anything. Turned off the car for about 10 minutes or so and when I turned it back on it seemed to be normal, everything was at least working that way. So I decide to just cut my journey short and head home, as Im at a stop light my car turns completely off and wouldn't start but everything in the dash was still lit. Finally getting it home (tow) I started to speculate that it was the headlight combo switch. but then got confused because my windshield wipers weren't working correctly a couple days before. They just started going at full speed when I was driving. 

as of today 01/15/17 I am about to change the fuel pump. My battery was drained so I took it to auto zone to get it charged Im just wondering whats draining it and kind of what are your opinions or if one of you guys experienced the same issue. please help guys, I need it! :sweat:

Link to post
Share on other sites

So sorry for the late reply. I actually found out that a chipmunk started chewing my wires. Got the car running and everything functioning normal except now my headlights wont turn on nor my dash and heater buttons. Turn signals work, tail lights work. Heater does turn on just doesnt produce heat to feet or through front vents. All meters work, gas gauge etc just no back light. 

I checked my wiring and also checked my fuses. Unfortunately Im probably just going to have to make a switch for my headlights as a temp but any suggestions? 

Link to post
Share on other sites

Where did you find chewed wires?  That is what I was going to suggest with the funny issues you have had.  A bunch of different wires shorting on eachother.  Can you pull back the wiring loom and re-splice (or at least individually tape) the wires to get them all into proper sheathing?

Link to post
Share on other sites

Driver side, near the battery. Im more than liking going to have to re-splice but in the mean time I created day time running lights. So everytime I turn my ignition my lights and dash back lights come on. Pretty proud actually lol

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...