Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
FIS

Quoting

Recommended Posts

So if I try to quote a post I get some random code along with the text I'm quoting.
Here is an copy of the code:

<script pagespeed_no_defer="">(function(){var g=this,h=function(b,d){var a=b.split("."),c=g;a[0]in c||!c.execScript||c.execScript("var "+a[0]);for(var e;a.length&&(e=a.shift());)a.length||void 0===d?c[e]?c=c[e]:c=c[e]={}:c[e]=d};var l=function(b){var d=b.length;if(0=d.offsetWidth&&0>=d.offsetHeight)a=!1;else{c=d.getBoundingClientRect();var f=document.body;a=c.top+("pageYOffset"in window?window.pageYOffset:(document.documentElement||f.parentNode||f).scrollTop);c=c.left+("pageXOffset"in window?window.pageXOffset:(document.documentElement||f.parentNode||f).scrollLeft);f=a.toString()+","+c;b.b.hasOwnProperty(f)?a=!1:(b.b[f]=!0,a=a<=b.e.height&&c<=b.e.width)}a&&(b.a.push(e),b.d[e]=!0)};p.prototype.checkImageForCriticality=function(b){b.getBoundingClientRect&&q(this,b)};h("pagespeed.CriticalImages.checkImageForCriticality",function(b){n.checkImageForCriticality(b)});h("pagespeed.CriticalImages.checkCriticalImages",function(){r(n)});var r=function(b){b.b={};for(var d=["IMG","INPUT"],a=[],c=0;c=a.length+e.length&&(a+=e)}b.g&&(e="&rd="+encodeURIComponent(JSON.stringify(s())),131072>=a.length+e.length&&(a+=e),d=!0);t=a;if(d){c=b.f;b=b.h;var f;if(window.XMLHttpRequest)f=new XMLHttpRequest;else if(window.ActiveXObject)try{f=new ActiveXObject("Msxml2.XMLHTTP")}catch(k){try{f=new ActiveXObject("Microsoft.XMLHTTP")}catch(u){}}f&&(f.open("POST",c+(-1==c.indexOf("?")?"?":"&")+"url="+encodeURIComponent(b)),f.setRequestHeader("Content-Type","application/x-www-form-urlencoded"),f.send(a))}}},s=function(){var b={},d=document.getElementsByTagName("IMG");if(0==d.length)return{};var a=d[0];if(!("naturalWidth"in a&&"naturalHeight"in a))return{};for(var c=0;a=d[c];++c){var e=a.getAttribute("pagespeed_url_hash");e&&(!(e in b)&&0=b[e].k&&a.height>=b[e].j)&&(b[e]={rw:a.width,rh:a.height,ow:a.naturalWidth,oh:a.naturalHeight})}return b},t="";h("pagespeed.CriticalImages.getBeaconData",function(){return t});h("pagespeed.CriticalImages.Run",function(b,d,a,c,e,f){var k=new p(b,d,a,e,f);n=k;c&&m(function(){window.setTimeout(function(){r(k)},0)})});})();pagespeed.CriticalImages.Run('/ngx_pagespeed_beacon','http://mazda626.net/index.php?s=3a6c3d82d93c01d73944966e1573ea89&app=forums&module=ajax%C2%A7ion=topics&do=quote&t=40901&p=389491&md5check=57b151314ab884d54d1017a0ffa5629c&isRte=1,gAGkv61Udl,true,false,SGFuE1KIAwI%27'>http://mazda626.net/index.php?s=3a6c3d82d93c01d73944966e1573ea89&app=forums&module=ajax%C2%A7ion=topics&do=quote&t=40901&p=389491&md5check=57b151314ab884d54d1017a0ffa5629c&isRte=1,gAGkv61Udl,true,false,SGFuE1KIAwI%27);'>http://mazda626.net/index.php?s=3a6c3d82d93c01d73944966e1573ea89&app=forums&module=ajax

Share this post


Link to post
Share on other sites

I have gotten the same... Dont remember where tho...

Share this post


Link to post
Share on other sites

Happened to someone that quoted me a couple days ago.  Figured it was a glitch and they edited the quote or messed up somehow. 

Share this post


Link to post
Share on other sites

Firefox on Windows running the latest version, I also get the same problem with the Steam browser.

Share this post


Link to post
Share on other sites

Firefox on Windows running the latest version, I also get the same problem with the Steam browser.

I saw this the other day when RacerX quoted someone. I am also using the latest Firefox on Windows 8.1. Are you using the WYSIWYG? Quick reply?

Share this post


Link to post
Share on other sites

Yes, I press the quote button on the post and write in the quick reply box, doesn't look like a problem on my iPhone with the stock browser and mobile version.

Share this post


Link to post
Share on other sites

I was able to reproduce this with Firefox on an old Vista machine. It's not content that's in the original post, my bet is it's some sort of buffer overflow due to the large volume of quoted text exceeding the array allocation. You are probably getting some sort of code in the adjacent memory.

Share this post


Link to post
Share on other sites

pagespeed disabled, try now plz, and post results.I'll test from my end of FFox too.

Share this post


Link to post
Share on other sites

pagespeed disabled, try now plz, and post results.I'll test from my end of FFox too.

 

Looks ok here.

Share this post


Link to post
Share on other sites

Both posts are fine now for me on the same computer I had the problem with :)

Share this post


Link to post
Share on other sites

excellent! For now, buh bye google pagespeed! Might revisit readding it in the future when I have more time to finely tune the settings and reduce issues like this. Glad this fixed the issues, easy fix!

Share this post


Link to post
Share on other sites

excellent! For now, buh bye google pagespeed! Might revisit readding it in the future when I have more time to finely tune the settings and reduce issues like this. Glad this fixed the issues, easy fix!

What does the pagespeed do? I never noticed any changes, but I never searched much on google :P

Share this post


Link to post
Share on other sites

pagespeed is a server module from google thats supposed to improve load times, its possible it wasnt setup correctly which is why we had some issues and the site actually feels faster without it. I used essentially a template for installing it, its also possible it was conflicting with additional caching/site performance mechanisms we use in addition to it. Technical mubo jumbo: https://developers.google.com/speed/pagespeed/module/configuration 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×