Florida Boy

1998 Mazda 626 Idle Problem

16 posts in this topic

Hello, I have a 98 Mazda 626 i4 lx. In the last couple of weeks when ever I have waited at a red light the RPM's have been fluctuating between 500-750 and this causes the car to vibrate and shake a lot. The check engine light has been on for a while so i decided to get it checked out. At the auto parts store they ran a diagnostic and this code came back, P1131. Any additional help would be appreciated. 

Share this post


Link to post
Share on other sites

means it's running lean ....most probable causes would be either a vacuum leak, fuel injector problem, PRC solenoid or faulty O2 sensor 

Share this post


Link to post
Share on other sites

FYI.  The only place I was able to find that hose, dealer.  Around $20. 

Share this post


Link to post
Share on other sites

Thank you for the reply, I will check that out. I took a picture of the air filter and was wondering if that could be the problem

 

https://www.flickr.com/photos/130017611@N07/16017276071/in/photostream/

 

https://www.flickr.com/photos/130017611@N07/16019229935/

I doubt the cracked hose is the problem. Try duct taping it and see what happens.

Share this post


Link to post
Share on other sites

Agreed, that hose won't cause a lean condition as it's upstream of the MAF. However, you probably have a hose in similar condition on the other side of the MAF.

Share this post


Link to post
Share on other sites

 

Thank you for the reply, I will check that out. I took a picture of the air filter and was wondering if that could be the problem

 

https://www.flickr.com/photos/130017611@N07/16017276071/in/photostream/

 

https://www.flickr.com/photos/130017611@N07/16019229935/

I doubt the cracked hose is the problem. Try duct taping it and see what happens.

 

you were right, i taped up the tear but the idle was still rough. I will take it to the shop sometime this week

Share this post


Link to post
Share on other sites

Agreed, that hose won't cause a lean condition as it's upstream of the MAF. However, you probably have a hose in similar condition on the other side of the MAF.

do you think the hose on the other side could cause a vacuum leak, or could it be a bad or dirty MAF?

Share this post


Link to post
Share on other sites

I'm suspecting it's running lean due to the low idle. Can you shoot the timing? And try clamping down on the brake booster hose with a plier. If idle improves, the booster is leaking. And does it start the same as before or does it take a little longer? 

Share this post


Link to post
Share on other sites

Hello Somebody knows if the MAF - f82f-12b579-da and MAF f82f-12b579-ea are the same? i have a 626 98 ENGINE FS37948 GLX UE VERSION 2.0L I HAD THE DA but i bought a ea by mistake they are the same ? can i use it?

Share this post


Link to post
Share on other sites

Thank you for all the suggestions. Unfortunately the car still has a very rough idle and now it started stalling at red lights. Yesterday I cleabed the MAF and problem went away temporarily. Do you guys know of another cause of this problem?

Share this post


Link to post
Share on other sites

Are you getting any DTC's now? When was the last time a tune-up was done? (plugs, wires, air filter, pcv valve, fuel filter)

Share this post


Link to post
Share on other sites

Yes, unfortunately I am still getting the p1131 code. My car has about 130k miles and the plugs and wires were changed at 80k. The air filter was changed 2 weeks ago, I have never changed the pcv valve, and the fuel filter was changed 2 months ago. I have looked into a solution and I was wondering if the o2 sensor could be bad?

Share this post


Link to post
Share on other sites

Are you getting any DTC's now? When was the last time a tune-up was done? (plugs, wires, air filter, pcv valve, fuel filter)

I took it to the mechanics today, it turns out to be a vacuum leak but there were other factors to the problem as well. The spark plugs were bad and the fuel injectors needed to be replaced and the pcv valve also needed fixing. Looks like I am going to go broke lol

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now