Jump to content

Recommended Posts

I need some help with my 95 626...i have a clunk noise when i turn dont matter if i turn left or right...it only does it one time per turn i checked cv axle,tie rods,control arm bushings...it only does it when im turning...any info would b appreciated. ..thanks in advance

Link to post
Share on other sites

The buahings on ball joinst r still in good shape and tie rod ends dont any play in them...ill check my strut bolts i have not looked at that...someone also said it could b a moter mount do u think it would make that noise only when im turning

Link to post
Share on other sites

Actually yes that was a great suggestion.  Since it happens when you turn check the driver and passenger side mounts.  If it happens when you slow down for a turn but not when you accelerate in a turn then check the front mount too.  If only happens when you accelerate into a turn but not when you slow down into a turn then check the rear mount.  The rear mount is a pain in the ass to inspect.  You can barely see it let alone inspect it.  Use a crowbar and leverage on the mounts to see if you can get them to clunk.  Clunking mounts means there is no rubber between the mount and mounting bracket.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...