Jump to content

Mazda 626 Wont Start After Ran For Awhile


Recommended Posts

i have a 2001 mazda 626 with the 4cyl you can crank it up and it runs great and you run it for awhile r keep killing it and turning it on then it will stop cranking up if you let it sit for a while it will crank back up. i tested the fire it is getting fire. can anyone help me out here on what it might be?

Link to post
Share on other sites

Wait you said it stops cranking as in the starter motor doesn't turn the engine over anymore? If that's the case then that has nothing to do with the sensors. That would be a battery or starter issue. Since you wait for a period of time then it cranks back over that leads me to believe it's a dead battery issue.

Link to post
Share on other sites
  • 2 years later...

I'm no expert, but I used to own a truck that was leaking transmission fluid and whenever it was low on fluid it would stall at traffic lights, I would check transmission fluid and see if it is low, check hoses for leaks if the fluid it's low, on my truck it was a simple $6 hose fix, thats all I can think of from my personal experience, but I'm new to mazdas..

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...