Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
NDM

Fixing The Two Biggest Issues With The Forum

Recommended Posts

No drastic front end changes here, but were going to be doing some changes to fix two major issues that have been persistent for the last 2months - 1 year.

  1. Email notifications:
    Not getting sent, not getting sent on time, not getting sent at all etc. We've had alot of email issues over the last year, and were switching to Mandrill (mailchimps relatively new mail delivery service). Also don't worry just because were switching over to this service doesn't mean your emails will be exposed to those pesky spammers. Issue discussion topic was here: http://mazda626.net/...-notifications/
    Just as a sidenote emails might be a little slow for the first 24-48 hours, during this time we have limits until they can verify were not a spammer trying to use MailChimps service.
  2. Fresh Content Not Showing Up:
    Some issues with posts not showing up right away. Due to a new html accelerator we enabled to reduce some of the load on the server logged in members are having some issues with not seeing posts show up right away. So well be fixing this very soon, by disabling this particular accelerator for members, and making it only be used by guests on the site.
    Issue discussion topic was here: http://mazda626.net/...ts-not-showing/

  • Like 1

Share this post


Link to post
Share on other sites

Sounds good. The new content not showing up was annoying because I'm always thinking of stuff to add right after I post and need to edit... but it wouldn't show up to edit. Good to know that's gonna get resolved soon. It was annoying.

Share this post


Link to post
Share on other sites

It was actually really strange. If I edited a post right after I posted it, the edits would show up right away. But if I made a 2nd edit or 3rd or whatever, none of those would show up for quite a while.

The whole thing was a royal pain in the butt. Really happy to hear it's getting fixed!!

Thanks heaps NDM!! :biggrin:

Share this post


Link to post
Share on other sites

The re-edit post after 2x only bothered me when I was using my phone to post. But it worked fine when I was using my computer to re-edit it.

Share this post


Link to post
Share on other sites

Is the site getting a significant amount of traffic above what we were getting when we got the new server? I remember that thing was pretty smokin' as far as stats go, plus it had a crazy NASA-like connection.

Share this post


Link to post
Share on other sites

Is the site getting a significant amount of traffic above what we were getting when we got the new server? I remember that thing was pretty smokin' as far as stats go, plus it had a crazy NASA-like connection.

The site should be able to handle probably 100-200x the volume of traffic were currently getting. The server is probably way more than we need, but its blazing fast thats for sure.

Right now we have about 40,000 unique visitors a month, with 130,000 pageviews each month.

At any given time during the day we usually have 10-15 visitors/users simultaneously viewing/interacting with the site.

Share this post


Link to post
Share on other sites

Wow!! it started when Prince said NASA-like connection,.. then it really hit me when NDM gave out all those numbers,... :blink: you guys are awesome!

never really had the re-edit problem,.. and i dont have the email notification thing,.. since i check mazda626.net first before my email :lol: just wanna ask,.. did we just change our server? :blink: im getting this funny "SQL error" last time,.. never seen that before. usually its the cloud flare thing.

em i missing something :huh:

Share this post


Link to post
Share on other sites

I got some email notifications the other day for the first time ever. It was weird and unexpected. I was like oh yeah I did subscribe to that topic how bout them apples.

Share this post


Link to post
Share on other sites

Wow!! it started when Prince said NASA-like connection,.. then it really hit me when NDM gave out all those numbers,... :blink: you guys are awesome!

never really had the re-edit problem,.. and i dont have the email notification thing,.. since i check mazda626.net first before my email :lol: just wanna ask,.. did we just change our server? :blink: im getting this funny "SQL error" last time,.. never seen that before. usually its the cloud flare thing.

em i missing something :huh:

Fade when did you get that SQL error?

was it within the last 24 hours or was it ~Fri, Oct 12, 2012 at 2:37 PM Eastern time GMT -5? Because I saw the issue pop up there but I haven't seen it since then.

I got some email notifications the other day for the first time ever. It was weird and unexpected. I was like oh yeah I did subscribe to that topic how bout them apples.

Yeah its nice to finally have a rock solid transactional email service. Now everyone gets the notifications they are supposed to :thumbsup:

Share this post


Link to post
Share on other sites

sorry,.. i cant remember exactly,.. NDM sir :unsure: but i do remember it being around noon,. :logik:

Share this post


Link to post
Share on other sites

not a problem, just be sure to let us know if you see it again.

We generally get notified via http checks the instant the site is down, so we usually tame it pretty quick if any problems rise up.

Share this post


Link to post
Share on other sites

I get loads of mails every day, even if i said i wanted a daily digest :S

Share this post


Link to post
Share on other sites

Ohh, and a little wish: an auto image resizer, so that the images are viewed as (Small, max 800 wide) thumbs...

Share this post


Link to post
Share on other sites

I get loads of mails every day, even if i said i wanted a daily digest :S

interesting so even if you change this setting:

post-15320-0-58563600-1350656138_thumb.p

It still sends daily notifications?

Ohh, and a little wish: an auto image resizer, so that the images are viewed as (Small, max 800 wide) thumbs...

The difficult part about this one, is anything uploaded through our image uploader/file uploader does get thumbnailed. But when somone uploads an image from another site we have a script that grabs that image so we will never lose it and uploads it to our CDN (For faster downloads for everyone). I can definitely take a look into this, but I think also the reason a lot of members upload external images is to get the full size ones because their easier to see at first glace (despite being slightly larger).

Share this post


Link to post
Share on other sites

interesting so even if you change this setting:

post-15320-0-58563600-1350656138_thumb.p

It still sends daily notifications?

I want to get one mail every day about new stuff. Not like now when i get one new mail every 10 min during the night :P Waking up to 30+ mails from the forum is poop, when all 30 are from replies in the same thread.

This is my current settings, and i have gotten emails the last 2 months without problems (if other people have):

(note that i just recently changed from imidiate to daily digest)

post-8310-0-23204400-1350657781_thumb.jp

The difficult part about this one, is anything uploaded through our image uploader/file uploader does get thumbnailed. But when somone uploads an image from another site we have a script that grabs that image so we will never lose it and uploads it to our CDN (For faster downloads for everyone). I can definitely take a look into this, but I think also the reason a lot of members upload external images is to get the full size ones because their easier to see at first glace (despite being slightly larger).

Yeah, i noticed that:)

The reason i upload from external places is because i want to keep the pictures myself, and also because im uploading them to several forums.

Some sites let me upload, some dont, so if im posting on all of them, i usualy just copy/paste the picture links from one thread to another, thus making the "attachement" option prettu useless to me for my project posts. The Script on the other hand is _VERY_ good , but it should auto resize huge images to a more viewable size.

The problem starts when my "fullsize" upload is large, and someones screen is small. It you look at my project thread, the last pictures are a tad to huge (and i dont seem to be able to "re-upload") smaller versions.

So, my recomendation is to set a "thumb" size at something like 800px wide max, or 700 like the current "thumbs", with a "click to enlarge" like today. I agree with Prince that small thumbs sucks, but so does a 24902234x123213123 image aswell.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×