Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Sign in to follow this  
Fuelman

Cruise Control Doesn't Work When Headlights Are On...

Recommended Posts

Mazda 626 1999

Mileage 248,000

4 cylinder

Automatic Transmission

(Original Owner)

I have a number of issues and they all started at the same time/day. Problem showed up last November 2009.

1. The cruise control works, but as soon as I turn on the headlights the CC turns off. If the headlights are turned on the CC will not turn on, but if the headlights were off, CC works fine.

2. If I step on the brake, the dash lights come on. It doesn't matter if the car is turned on or off, the dash lights come on both ways. The brightness of the dash lights is dim, this is best observed at night.

3. When I use the CC, after a day of use the Check Engine light comes on and gives a code in reference to the transimission. If I don't use the CC, for a day, the CE light goes off. I've not used the CC in the last month and the Check Engine light has not come back on. Not even once!!

Outside of these issues, the car runs great.

Share this post


Link to post
Share on other sites

Sorry so late in replying back, I never received an email telling me I got a reply to my question.

I removed the under hood fuse box and looked at the wires, I didn't see any indication of melted wires anywhere. There has to be wires touching somewhere under the hood or steering column, but I haven't found it yet. Thanks woo7 for the suggestion, if you have anymore please let me know.

Share this post


Link to post
Share on other sites

Mazda 626 1999

Mileage 248,000

4 cylinder

Automatic Transmission

(Original Owner)

I have a number of issues and they all started at the same time/day. Problem showed up last November 2009.

1. The cruise control works, but as soon as I turn on the headlights the CC turns off. If the headlights are turned on the CC will not turn on, but if the headlights were off, CC works fine.

2. If I step on the brake, the dash lights come on. It doesn't matter if the car is turned on or off, the dash lights come on both ways. The brightness of the dash lights is dim, this is best observed at night.

3. When I use the CC, after a day of use the Check Engine light comes on and gives a code in reference to the transimission. If I don't use the CC, for a day, the CE light goes off. I've not used the CC in the last month and the Check Engine light has not come back on. Not even once!!

Outside of these issues, the car runs great.

I have just started having the exact same issues with my 96 4 cyl automatic. Did you find any answers to this problem?

Thanks!

Share this post


Link to post
Share on other sites

Check the light bulbs in your car; many of them are dual-filament. If the circuit for one filament back-feeds into the other, you can get some strange symptoms. Sometimes one filament will burn through on one end, and it will fall and land on the other, shorting the two circuits together. I've also seen cases where the lead used in the contacts on the bulb base mushrooms out over time (the bulbs are under spring pressure when in the socket), and the two contacts eventually touch each other. In this case, you can use a knife and cut away the mushroomed piece bridging the two together.

I think your cruise control may be cancelling because power is being back-fed into the ground wire for the dash lights (there's a light that indicates "cruise" is enabled you know). That's your common link, the gauge cluster. Turning lights on or stepping on the brakes both cause certain aspects of the gauge cluster to illuminate, and both of them illuminate bulbs in the taillight cluster.

It seems to mee you have a shorted taillight bulb, and it backfeeds current [or shorts out] the cruise control via the gauge cluster.

Share this post


Link to post
Share on other sites

Maybe there are some problems with your wirings? I had the same problem, I just found out that my wirings are jammed.

_______________________________________________

need a cruise control kits for my project car (mazda 232 96')

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×