Jump to content

Search the Community

Showing results for tags 'water pump'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • News, Competitions, and Announcements
    • General Chat (Sixers Lounge)
    • Feedback
    • Regional
  • Questions and Technical Support
    • 1993-2002 (2.5L) V6
    • 1993-2002 (2L) I4
    • 1988-1992 (2.2L | 2.2L Turbo)
    • 1983-1987 (1.6L | 2.0L | 2.0L Turbo)
    • 1978-1982 (2.0L)
    • Other 626's
  • Supporting Vendors
    • RockAuto
    • Atkins Rotary
  • Performance and Tuning
    • 1993-2002 (2.5L) V6
    • 1993-2002 (2L) I4
    • 1988-1992 (2.2L | 2.2L Turbo)
    • Other 626's
  • Appearance Modifications Section
    • Audio & Electronics
    • Lighting
    • Detailing
    • 1998-2002
    • 1993-1997
    • 1988-1992
    • Other 626's
  • Enthusiast
    • Tutorials & How To Guides
    • Reviews
    • Photo Section
    • Projects/Builds
    • Driving Stories
  • Merchandise and Shopping
    • For Sale / Trade
    • Hot Deals / Free Stuff / Contests

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


eBay


Location


Interests


Car

Found 10 results

  1. hi folks, im having an issue with my engine over heating and am wondering if anyone could help. the engine has been squeaking for a while which at first i thought was a belt, although having changed it turns out that wasn't the problem. the other night i was driving home from work and the engine light came on the dashboard, i checked the engine temperature and it was at the top of the gauge. after i pulled over, all the coolant spurted out from somewhere close to reservoir (i guess there was too much pressure). as there is squeaking and the engine is overheating, i can o
  2. hi folks, im having an issue with my engine over heating and am wondering if anyone could help. the engine has been squeaking for a while which at first i thought was a belt, although having changed it turns out that wasn't the problem. the other night i was driving home from work and the engine light came on the dashboard, i checked the engine temperature and it was at the top of the gauge. after i pulled over, all the coolant spurted out from somewhere close to reservoir (i guess there was too much pressure). as there is squeaking and the engine is overheating, i can o
  3. My car recently started overheating. 1996 Mazda 626 V6 220,000 miles We did replace the thermostat. I have the water pump but havent put it in yet as it appears to be quite a chore and wanted to get an opinion before I replace it. When it sits in idle with nothing on its fine temp gauge rests in the middle. Went for a short 7 minute drive and it slowly lifted to the H position. Today I had it parked and just ran it, it was fine. I turned on the heater and it took several minutes for it to rise above the middle section of the gauge. I switched to AC and it rose steadily to the H p
  4. Hello all. My car has been leaking coolant for about 5 months now. First it was leaking from the resevoir itself (It would over flow). Now it's not leaking from the resevoir and rather from under the engine on the passenger side close to one of the belts. Then when it got super cold about a month ago, the tail pipe started smoking white or blue smoke. It smells sweet like coolant. However, my car has never over heated. At least not since me and my dad changed the radiator about a year and a half ago. It's been fine. I sent pictures to my mechanic of the leak and the smoke. He sai
  5. Hey! I just bought a 1998 626 (automatic) and the day after I bought the car, it overheated! Unfortunately when I test drove the car, neither my boyfriend or I noticed this. Well, because it didn't overheat on the test drive, or the drive home. So my question, to anyone else who may have has the same problem is why is this happening? Some more things to know: When it first overheated, the upper radiator pipe was steaming (I had a freak out and thought my engine was getting ready to blow) but luckily the radiator part with a lip that fits in the upper radiator hose was broken. So my boyfri
  6. Hello Guys, I have a 2002 mazda 626 4 cyl 2.0 l automatic with 116k miles on it. My water pump has started leaking coolant, and it needs to be replaced, i was wondering if anyone has done this by themselves before? if anyone can give me some steps or some insight about the difficulty with this particular model. I am somewhat mechanically inclined as i have always changed my own brake pads and little things like that. Any advice would be greatly apperciated. thanks
  7. I've spent 3K on my 2001 626 V6 in the last year. 118K miles I've replaced: Harmonic Balancer, timing belt and cover, radiator, overflow tank (twice), and had two oil leaks fixed. A week ago I had a bad water pump replaced right before it fell apart and I had leaking power steering pump too (had no sign that was bad) My car engine started smoking today and I thought I smelled burning oil. The power steering is making a loud humming noise and a grinding sound when I turn to the extreme right. The smoke seems to be coming from the right hand side around and down below the engine area. I hav
  8. I have a 1998 Mazda 626 4 cylinder. I had my timing belt replaced over 12,000 miles but less than a year ago. In June of this year I needed a new water pump. I took it to a different shop than the replacement of my timing belt to replace the water pump. 2 days ago I hear a revving noise and pull over and notice the bolt is off of the idler pulley. I drive it to the 1st garage thinking it was there fault but warranty was out. Have it towed to the 2nd garage and they said they never messed with the idler pulley but they did take off the timing belt to replace the water pump. I don't know much a
  9. I have a 96 626 2.0, i recently replaced the water pump, now the car has a rough idle and lags when i accelerate. Timing belt was marked prior to installation, so it shouldnt be the issue. When I put it in gear and hit the gas the car just lags like it doesnt have any power, once I come to a stop or am in traffic, the car will sputter and idle will drop very low and it sometimes stalls. Any help would be appreciated. Thanks
  10. Hello everybody. I am new to this forum, Mazda 626's and fixing cars in general. If there are any introductory articles that I should read before attempting to DIY, please point me in the right direction. Also, what is the best manual to get for fixing Mazdas? I recently bought a 2000 Mazda 626 V6 (Automatic) with around 160 000 km on it. It was working great for the first couple hundred kilometres. Shortly after buying the car, the CEL came on. I didn't notice anything out of the ordinary at this point. After driving the car a little longer, I noticed a large pool of liquid in my dr
×
×
  • Create New...