Jump to content

Search the Community

Showing results for tags 'upper'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • News, Competitions, and Announcements
    • General Chat (Sixers Lounge)
    • Feedback
    • Regional
  • Questions and Technical Support
    • 1993-2002 (2.5L) V6
    • 1993-2002 (2L) I4
    • 1988-1992 (2.2L | 2.2L Turbo)
    • 1983-1987 (1.6L | 2.0L | 2.0L Turbo)
    • 1978-1982 (2.0L)
    • Other 626's
  • Supporting Vendors
    • RockAuto
    • Atkins Rotary
  • Performance and Tuning
    • 1993-2002 (2.5L) V6
    • 1993-2002 (2L) I4
    • 1988-1992 (2.2L | 2.2L Turbo)
    • Other 626's
  • Appearance Modifications Section
    • Audio & Electronics
    • Lighting
    • Detailing
    • 1998-2002
    • 1993-1997
    • 1988-1992
    • Other 626's
  • Enthusiast
    • Tutorials & How To Guides
    • Reviews
    • Photo Section
    • Projects/Builds
    • Driving Stories
  • Merchandise and Shopping
    • For Sale / Trade
    • Hot Deals / Free Stuff / Contests

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


eBay


Location


Interests


Car

Found 1 result

  1. Hello there, first of all thanks for all of you guys working this forum. I've been able to fix this 626 I got. I'll be short: I've been experiencing coolant loss, checked all hoses, no punctures, my overflow tank "over fills" and I get coolant out (I top it just a tad bit over low level, say, mid level, and after driving for a relative mid distance I check the tank and it's topped). So I checked the hose that's below the overflow tank (overflow tank needs replacing, will get this weekend), disconnected it and blew air inside and into what I call "thermostat housing", and to my
×
×
  • Create New...