Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

Search the Community

Showing results for tags 'stock'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • News, Competitions, and Announcements
    • General Chat (Sixers Lounge)
    • Feedback
    • Regional
  • Questions and Technical Support
    • 1993-2002 (2.5L) V6
    • 1993-2002 (2L) I4
    • 1988-1992 (2.2L | 2.2L Turbo)
    • 1983-1987 (1.6L | 2.0L | 2.0L Turbo)
    • 1978-1982 (2.0L)
    • Other 626's
  • Supporting Vendors
    • RockAuto
    • Atkins Rotary
  • Performance and Tuning
    • 1993-2002 (2.5L) V6
    • 1993-2002 (2L) I4
    • 1988-1992 (2.2L | 2.2L Turbo)
    • Other 626's
  • Appearance Modifications Section
    • Audio & Electronics
    • Lighting
    • Detailing
    • 1998-2002
    • 1993-1997
    • 1988-1992
    • Other 626's
  • Enthusiast
    • Tutorials & How To Guides
    • Reviews
    • Photo Section
    • Projects/Builds
    • Driving Stories
  • Merchandise and Shopping
    • For Sale / Trade
    • Hot Deals / Free Stuff / Contests

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


eBay


Location


Interests


Car

Found 2 results

  1. Hi Everyone I was wondering if anyone ever tried to install the OEM / original / default / factory radio, of a 2nd generation Miate / MX5 into the DIN slot of a 5th generation Mazda 626 (1992 - 1997). Both looks like it has space for a Double DIN radio. The one in the MX5 sure looks like one, and I was thinking of installing a MX5 radio into my Doube DIN slot of my 626 (Ford Telstar TX5 version). Anyone tried this yet?
  2. danielturneyy

    Factory Amp 95 Mazda 626 Lx V6

    Hey could use a little help. If anyone knows where the factory amp is located in a 1995 mazda 626 lx v6 thats all i really need help with. Cause I my speakers were all working, then turned off my car for 5 min and turned it back on and there was no sound. deck and everything works but speakers aren't blown cause you would hear some static but its dead silence anyone know what the problem could be?
×