Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

calhouns

Members
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About calhouns

  • Rank
    Newbie
  1. I've read a lot by now about an aftermarket radio messing up the dash illumination lights. Here's my story: I have a 2002 626 and put in a Boss radio about 6 months ago. All was good until I went to the car wash about month ago. Water must have messed stuff up, b/c about a day after the wash, the speakers went out. Then they came back on for a few days and then went out for good. Then I found the blown fuse for the tail lights and the dash illumination. I replaced the fuse and all was good for a week. Now the illumination lights are out. I've blown fuses for the illumination light about 10 times trying to get them on again. I've been checking the radio wiring too and keep blowing the 10 amp illumination fuse. When I installed the radio last fall, all was good. The radio does not have orange wires coming from it, but the harness adapter has an orange and orange white which I left loose and never attached to anything. Like I said, all was good for many months. Now it seems nothing is going right. No sound from the speakers. No illumination lights. What should I try next? What should I do with the orange wires? When I touch the orange/white wire to the constant on 12v yellow, I get illumination that's always on but then the fuse blows. Help!
×
×
  • Create New...