Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

patrickgallaher

Members
  • Content Count

    2
  • Joined

  • Last visited

Community Reputation

0 Neutral

About patrickgallaher

  • Rank
    Newbie
  1. hars to start, extened crank, after warm up, runs fine after starts, fuel press good 34-44, cleared codes, lite comes back on
  2. I have a 99 626 and after replacing the fuel pressure regulator and fuel filter the fuel pump does not come on with the key as it should and the car is hard to start. it will no longer idle. Previously it was difficult to start and revved to ~4000 and held there for 15-20 seconds and then returned to a slow idle and then fast idle loop between 600 slow to 2000 fast. My father and I have tested the fuel pressure relay by switching it with the same one from another location and have jumped around it to manually engage the fuel pump with success. The car does run so the fuel pump must be working. We also put the fuel pressure gauge between the pressure regulator and the return line to the gas tank and there is not pressure so it doesn't appear to have a blocked return line. I have also installed a new EGR valve as pressing the brake pedal made the RPMs jump and there seemed to be a very squishy pedal like it was a large loss of vacuum. A vacuum test shows good. I put in a PCM from a salvage yard car that was the same (automatic, 4 cylinder etc) That car was produced 16 days after my 626 so the code should be good. From that car I grabbed the 4 vacuum sensor relays that send signals to the PCM for the trims. I've swapped them out to see if it helped my problem with no luck. any help would be greatly appreciated Switching the PCM with my original does not change any of the problem characteristics.
×
×
  • Create New...