Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

Nargacuga11B

Members
  • Content count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Nargacuga11B

  • Rank
    Newbie

Previous Fields

  • Car
    1993 Mazda MX3 GS, 2.5L KLDE, Manual

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. I have a 93 MX3 GS that has been swapped with the 2.5L KLDE. The car was running until the clutch went out. It sat for 3 years before I acquired the car and replaced the clutch, alternator and battery. I drove it a few times before changing the plugs and wires, and I've gotten a crank/no start since. I've checked and double checked the wiring 100 times. The plugs were gapped correctly. The timing is good. The fuel pump is coming on and I'm getting fuel to the rail. I'm getting spark. I've replaced the distributor, ignition coil, ignition module, ECU, and ignition switch. Nothing. I noticed when I got the car that the guy who did the swap left the KL wiring harness on the motor and kind of spliced the K8 harness into. I knew it would be a problem eventually, but he had it running. I took the car to a shop, and they also told me I need a new harness. My issue is that I cannot find a K8 wiring harness anywhere. Out of all the websites and junk yards I've checked, I found 1, but they want a lot for it, imo. So, does anyone have any other ideas on what could be causing my crank/no start before I drop the money on this used harness? Does anyone know of anywhere else i should check for a harness first? Would it be viable to build a custom harness myself (I know some people that have done it)? And, if so, how and where do I find all the connectors I need? How expensive would this be? I know it's a lot, but I'm pretty lost at this point. Any help would be greatly appreciated.
×