Jump to content

Ranflee

Members
  • Content Count

    6
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Ranflee

  • Rank
    Newbie

Previous Fields

  • Car
    96 626. 2.0L. auto trans
  1. Just a follow up . The car is running fine since I fixed the loose ground strap. Only problem now is the open door light is on all the time . Must be a bad switch .
  2. Thank you snailman 153624 , I did a test on the vss that I saw on the Internet where you turn key on (with out starting), press o/d switch to turn on light. Then start car . According to the video if sensor was bad the car wouldn't engage into gear. The car in video did not, but mine did. However since last post I found another loose ground strap . Tightened it. So far , so good (it's been two days now). But not 100% convinced yet. So just I case any other suggestions are very welcome.
  3. I don't know why this posted three times . Sorry bout that
  4. Hi all, i have an issue with my granddaughters 96 Mazda 626. 2.0L auto trans Last year I had the trans rebuilt by a professional trans rebuilder. Did it on the side as a favor. Recently the car doesn't want to shift correctly , the o/d off light flashes , the tach speedometer and fuel gauges stop working . If you turn the car off and restart it doesn't shift at all until o/d off starts flashing again. Three obd codes come up po 340 camshaft position sensor po500 vehicle speed sensor and po 443 purge valve. Most mornings the car runs fine. On the way home right from the start it doesn't
  5. Hi all, i have an issue with my granddaughters 96 Mazda 626. 2.0L auto trans Last year I had the trans rebuilt by a professional trans rebuilder. Did it on the side as a favor. Recently the car doesn't want to shift correctly , the o/d off light flashes , the tach speedometer and fuel gauges stop working . If you turn the car off and restart it doesn't shift at all until o/d off starts flashing again. Three obd codes come up po 340 camshaft position sensor po500 vehicle speed sensor and po 443 purge valve. Most mornings the car runs fine most mornings car runs fine . On the way home rig
  6. Hi all, i have an issue with my granddaughters 96 Mazda 626. 2.0L auto trans Last year I had the trans rebuilt by a professional trans rebuilder. Did it on the side as a favor. Recently the car doesn't want to shift correctly , the o/d off light flashes , the tach speedometer and fuel gauges stop working . If you turn the car off and restart it doesn't shift at all until o/d off starts flashing again. Three obd codes come up po 340 camshaft position sensor po500 vehicle speed sensor and po 443 purge valve. Most mornings the car runs fine most mornings car runs fine . On the way home rig
×
×
  • Create New...