Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

rafy953

Members
  • Content Count

    11
  • Joined

  • Last visited

Everything posted by rafy953

  1. My 1992, 626 model DX 2.2 L is leaking oil through the side apparently between the head and the block. This motor was repaired 3 yrs ago, would not expect to have any leaks in that area so soon. But is consuming like one quart every 3 to 4 weeks depending on the routine, if i go on long trips is more like two or three days. I suspect that the head bolt have lost clamping pressure, is that possible? would re torquing the head do? Would gladly appreciate some light on this. Thanks PS: Recently replaced oil pressure sender the crankshaft and camshaft seals.
  2. i resently replace the strut bearing plates oem, no longer than 3month ago, the spring seat of the passenger side broke for unknown reason, other than it was to old. never the less i dont trust that it was assembled the whrite way, reason for my dought is that the bearing plate before i replace them had broken to. maybe the spring or the bearing plate was assembled wrong and caused to put extra stress on the rubber in these parts. does any one have the section "R" of the shop repair manuals, or a sketch of how it should be assembled? Like always grately apreciate the help you guys always offer, thanks in advance
  3. Thanks to you guy's for your effort. How much should i pay for one of these cables? There is a fellow in Australia who is selling a shifter and in his photo he shows the cable, this is a right handed car and what he is really selling is the shifter as is in the photo. I have my dough's if it would fit or if the cable is part of the package. What are your though's? Thanks again
  4. While replacing all the bushings on the shifter and the transmission. after assembling every thing together and in the calibration procedure i notice the shifter would move but not light on the dash board did, Then i pulled the adjusting shaft and moved like 1.5in. disassembled the cable and the portion on the transmission side came off. Tried to locate one on the local auto parts, ebay, rockauto, junkers and nothing. Can this be repaired? Does any one out there know of anyone who is willing to sell one for a reasonable price? Or just guide to a source to buy. Thanks, Rafy
  5. thanks for the help so far, now i'f got my hands full, so let me get to work and i'll get back to you guys with any progress. ps: XeNoMoRpH, how or where can i get a copy of this Factory Service Manual thanks again ooops..... thanks for the site. djdevon3 it is an eye opening experience the info here
  6. Does anyone have a picture or diagram of the routing of the cable that goes from the throttle body to the automatic transmission? And how can I solve a problem with the neutral switch, I have to swaggle the shifter and go from parking to reverse to get the car to start.
  7. when I was pulling the engine out the converter leaked a considerable amount of oil and I replaced 4 qrts. till it came to full operating condition. the filter is the same, so i 'll go with vacuum hose approach. Could this also have to do with the governor?
  8. my car 1992 626 dx auto trany. my car does not down shift when going up a hill or accelerating to pass. it up shifts ok at normal driving, resent rebuilt engine.
  9. does anyone have torque specs. including rod and main. thanks
  10. Guys, Thanks for all your inputs. after doing many suggested ideas seams like all the above; car finally over heated and and head gasket busted. Seams like the coolant sensor was giving bad readings. After taking apart the engine noticed a very severe corrosion in the cooling system lots of scaling in the block and the head, coolant passages had to be welded. Preventive maintenance was the real cause for all these issues to arise. Hope rebuilding the engine will cure all the problems w/high idle rpm. For future members looking for solutions to a problem similar to mine all the above where excellent inputs. Temperature sensor was the prime offender. Thanks again.
  11. Car runs ok, but when it decelerates and comes to a stop, idle speed run so high the car wants to keep going. Checked for air leakage, throttler jaming,a ok. Can it be related to the IAC (Idle Air Control)? Need help, no past experience with EFI.
×
×
  • Create New...